CoreCommunity ExtensionsIncubatorDistributionsTYPO3 4.5 ProjectsTYPO3 4.7 ProjectsTYPO3 6.0 ProjectsTYPO3 6.1 ProjectsTYPO3 6.2 Projects (+)

Bug #13221

Validation messages are not in order.

Added by Harald no-lastname-given about 3 years ago. Updated over 2 years ago.

Status:Rejected Start date:2011-02-21
Priority:Must have Due date:
Assignee:Alexander Grein % Done:

0%

Category:-
Target version:-
TYPO3 Version:4.5 Has patch:
PHP Version:
Votes: 0

Description

Hello!
I'm using TYPO3 4.5 and PowerMail 1.6.0.
If I fill out the form in the FE or leave out fields, the validation messages are not positioned correctly. In addition to display too many messages (see the sent along Sreenshot). It will also validate messages appear when I fill out everything correctly?

If the on my installtion?

sreenshot.jpg (45.6 kB) Harald no-lastname-given, 2011-02-21 13:39

History

Updated by Harald no-lastname-given about 3 years ago

I've just noticed that the validation of the English language shift from German to not display too many messages. It is only in the standard view?

Updated by Alexander Grein about 3 years ago

  • Status changed from New to Needs Feedback

Sorry, but i can't understand you completely, but i thing the problem is located in your CSS file.

Please use firebug (or similar) to check your CSS code.

Updated by Harald no-lastname-given about 3 years ago

Hello!

I meant:

The validation will be shown during the filling and one Popup is too mutch (the last one in the screenshot i have also sent)

Many thanks

Updated by Björn Biege about 3 years ago

Hallo,

i thik this validation is comming from radio or checkbox-fields. Radiobuttons are validated always in my form, also i don't use validation in this fields. And than the validationpopup is in wrong position.

Updated by Harald no-lastname-given about 3 years ago

Hello!

Thank you for your support and your answer.
The problem with the popup that was too much is correctly described by you. I also find itself the cause soon.
What I fail to understand however, why the popup to show even if I type a text only (in each row)?
Am I really alone with this problem :-(

Thanks anyway

Updated by Alexander Grein about 3 years ago

Please try the latest trunk.

Updated by Josef Florian Glatz about 3 years ago

I've also the same behaviour with powermail 1.6.2. With powermail 1.6.0 the errormessages are shown on correct place.

to better describe it: http://typo3blog.at/fileadmin/user_upload/jousch/powermail-errormessages-bug/ (shortvideo)

I've also tried it with powermail trunk (18.3.2011) -> same error.

thanks in forward, I hope it will help a little bit....

Updated by Alexander Grein almost 3 years ago

Please try latest trunk version.

Updated by Nikolas Hagelstein almost 3 years ago

Confirmed on typo3 4.5.2 with
Powermail 1.6.3 and
Powermail 1.6.4-dev Rev 47886.

The problem is caused by jquery tools and has been introduced somewhere between version 1.2.4 and 1.2.5.

It seems as if https://github.com/jquerytools/jquerytools/blob/master/src/validator/validator.js
Function getPosition sometimes fails on calculation the correct position e.g.
Linie 107: top -= el.outerHeight() - conf.offset0;

jQuery's outerHeight seems to return way to high numbers for the validation message under some circumstances.
E.g. I get 700px on the initial "validation" and 26px on the 2nd. Not sure if this is site/css related or a general problem.

Cheers,
NIkolas

Updated by Alexander Grein over 2 years ago

  • Status changed from Needs Feedback to Under Review

Updated by Alexander Grein over 2 years ago

  • Assignee set to Alexander Grein

Updated by Alexander Grein over 2 years ago

  • Status changed from Under Review to On Hold
  • TYPO3 Version set to 4.5

Updated by Alexander Grein over 2 years ago

  • Status changed from On Hold to Rejected

This is an jQuery Tools issue.

More information can be found here: https://github.com/jquerytools/jquerytools/issues/430

Please give your +1 to speed up the implementation in the next jquery tools (dev) version!

Also available in: Atom PDF