Project

General

Profile

Actions

Bug #103966

closed

be edit of nested irre causes type error in Backend Utility

Added by Lina Wolf about 1 month ago. Updated 6 days ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
Backend User Interface
Target version:
-
Start date:
2024-06-03
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
13
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

How to reproduce:

Install TYPO3 13.1 and main-dev of blog_example: https://github.com/TYPO3-Documentation/blog_example

Go in the Backend module and hit "Generate data"

try to open one of the generated blogs.

There is a warning:

PHP Warning
Core: Error handler (BE): PHP Warning: Array to string conversion in /var/www/html/vendor/typo3/cms-backend/Classes/Utility/BackendUtility.php line 1534

This is due to the fact that $row does not only contain scalar values but seems to also contain arrays that cannot be casted to a string.

This was caused by trying to renderForeignRecordHeader in InlineRecordContainer:324 and seems to only happen when the record to be displayed in irre has ctrl->label_alt set and label_alt is pointing to a field which is a select box.

Actions #1

Updated by Lina Wolf about 1 month ago

Is resolved in main

Actions #2

Updated by Lina Wolf about 1 month ago

  • Status changed from New to Resolved
Actions #3

Updated by Benni Mack 6 days ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF