Bug #10516

F3\FLOW3\Package\Exception\UnknownPackageException thrown in file PackageManager.php

Added by Martin Eisengardt almost 11 years ago. Updated almost 11 years ago.

Status:
Closed
Priority:
-- undefined --
Assignee:
-
Category:
- Error Handler Report -
Target version:
-
Start date:
2010-10-28
Due date:
% Done:

100%

Estimated time:
PHP Version:
Has patch:
Complexity:

Description

This problem only occurs once under windows vista. Seems that some component is misbehaving/misusing he windows directory separator. It only occurs with empty data/temporary directory. Adding the following code in F3\FLOW3\Resource\Streams\ResourceStreamWrapper, line 499 to change windows style backslash to slash solved the problemfor me. Of course there should be a smarter fix.
$requestedPath = str_replace('\\', '/', $requestedPath);

Package "FLOW3\Private" is not available. Please note that package keys are case sensitive.
10 F3\FLOW3\Package\PackageManager::getPackage("FLOW3\Private")
9 F3\FLOW3\Resource\Streams\ResourceStreamWrapper::evaluateResourcePath("resource://FLOW3\Private")
8 F3\FLOW3\Resource\Streams\ResourceStreamWrapper::pathStat("resource://FLOW3\Private", 3)
7 F3\FLOW3\Resource\Streams\StreamWrapperAdapter::url_stat("resource://FLOW3\Private", 3)
6 RecursiveDirectoryIterator::hasChildren()
5 F3\FLOW3\I18n\Service::generateAvailableLocalesCollectionByScanningFilesystem()
4 F3\FLOW3\I18n\Service::initialize()
3 F3\FLOW3\Core\Bootstrap::initializeI18n()
2 F3\FLOW3\Core\Bootstrap::initialize()
1 require("D:\Dev\ws\bghosting_website\com_bghosting_flow3_de…wkflow3\Packages\Framework\FLOW3\Scripts\FLOW3.php")


Related issues

Is duplicate of TYPO3.Flow - Bug #11240: Set UNIX_PATHS flag when using RecursiveDirectoryIteratorResolvedBastian Waidelich2010-12-02

Actions
#1

Updated by Karsten Dambekalns almost 11 years ago

  • Status changed from New to Closed
  • % Done changed from 0 to 100

Also available in: Atom PDF