Bug #12210

Widget Bootstrapper Call to undefined method Tx_Extbase_Object_Container_Container::getContainer()

Added by Kevin Ulrich Moschallski almost 10 years ago. Updated almost 10 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Widgets
Target version:
-
Start date:
2011-01-14
Due date:
% Done:

0%

Estimated time:
Has patch:

Description

When calling a ajax widget i recieve this error:

Call to undefined method Tx_Extbase_Object_Container_Container::getContainer()

I looked into the class and couldn't find such a method.

I replaced it with this:

$objectContainer = t3lib_div::makeInstance('Tx_Extbase_Object_Container_Container');
$objectContainer->registerImplementation($originalClassName, $classConfiguration['className']);

and everything works fine.

Patch attached.


Files

12210.patch (780 Bytes) 12210.patch Kevin Ulrich Moschallski, 2011-01-14 12:11
#2

Updated by Kevin Ulrich Moschallski almost 10 years ago

Duplicate of #11991.
Can be closed.

#3

Updated by Sebastian Kurfuerst almost 10 years ago

  • Status changed from New to Closed

Also available in: Atom PDF