Bug #14298

RewriteRule "Feature"

Added by Peter Russ almost 17 years ago. Updated almost 15 years ago.

Status:
Closed
Priority:
Should have
Category:
Frontend
Target version:
-
Start date:
2004-08-31
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
3.6.2
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Rewriteing to a fix id e.g.
RewriteRule ^(.*\.html|/)$ index.php?id=5
always tries to deliver the page called with *.html as id is ignored.

It might be a solution to check if id is set at tslib_fe:checkAlternativeIdMethods() before doing the kill starting at line 505. But perhaps there is a reason to do so? No idea ;-)
(issue imported from #M322)


Related issues

Is duplicate of TYPO3 Core - Feature #14127: FE-Editing new pages and simulateStaticClosed2004-04-29

Actions
#1

Updated by Ingmar Schlecht almost 17 years ago

This bug is kind of a duplicate of that one: #0000036

Also available in: Atom PDF