Bug #185

Text rendering on documentation/reference/component-manager/ (possible duplicate)

Added by Rasmus Skjoldan over 11 years ago. Updated almost 9 years ago.

Status:
Resolved
Priority:
Should have
Category:
HTML / CSS
Target version:
-
Start date:
2008-02-07
Due date:
% Done:

100%

Estimated time:
0.00 h

Picture_11.png View (79.1 KB) Rasmus Skjoldan, 2008-02-07 23:33

Screenshot1.png View (340 KB) Robert Lemke, 2008-02-15 11:44

Screenshot2.png View (84.9 KB) Robert Lemke, 2008-02-15 11:44

History

#1 Updated by Karsten Dambekalns over 11 years ago

  • Status changed from New to Needs Feedback

Do you have JS enabled? The width is adjusted by some JS Julle wrote... Oh, and, what browser are you using?

#2 Updated by Rasmus Skjoldan over 11 years ago

Sorry - might be me. I'm on FF beta3 right now.

#3 Updated by Karsten Dambekalns over 11 years ago

  • Target version set to 1.0.0

#4 Updated by Karsten Dambekalns over 11 years ago

  • Status changed from Needs Feedback to Rejected

Considering a bug in FF3, no change required.

#5 Updated by Robert Lemke over 11 years ago

It appeared again.

Here are two screenshots made with Safari 3.0.4 on Mac (JS enabled!).

Page is: http://flow3.typo3.org/documentation/reference/aop-framework/

#6 Updated by Robert Lemke over 11 years ago

Weird: I can only reproduce the bug if I click on http://flow3.typo3.org/documentation/reference/aop-framework/ directly.
If I select a different page through the site navigation and go back to the AOP framework documentation by clicking the link in the 2nd level nav, it works fine.

#7 Updated by Robert Lemke over 11 years ago

  • Target version deleted (1.0.0)

#8 Updated by Thomas Hempel over 11 years ago

I don't know jQuery that well but does it support domready events?
If it does, I would propose to do the "$(doc.load);" in bells-and-whistles.js" on domready. To me it looks like the Browser did not rendered the page completely when the resize starts.

Greets,
Thomas

P.S.: This is just a guess because I can't reproduce this only on first load and if I clear my browser cache.

#9 Updated by Stefano Cecere about 11 years ago

problem still alive with latest Safari (3.1.2)

http://flow3.typo3.org/documentation/reference/aop-framework/

:(

#10 Updated by Karsten Dambekalns about 11 years ago

  • Estimated time set to 0.00 h

It could be that jQuery stumbles over a malformed DOM, because the HTML contains mismtatched tags:

Unmatched </br> encountered. Ignoring tag.
http://flow3.typo3.org/documentation/reference/aop-framework/ (line 256)
Unmatched </img> encountered. Ignoring tag.
http://flow3.typo3.org/documentation/reference/aop-framework/ (line 275)
Unmatched </hr> encountered. Ignoring tag.
http://flow3.typo3.org/documentation/reference/aop-framework/ (line 582)

This should be fixed in the XSLT generating the HTML.

#11 Updated by Karsten Dambekalns over 10 years ago

  • Category set to HTML / CSS
  • Assignee changed from Karsten Dambekalns to Christian Jul Jensen

#12 Updated by Berit Hlubek about 10 years ago

The notation $(function); seems to behave like $(document).ready() so I'd think that a missing domready event couldn't be the problem.

I tested everything locally width valid source code, but the problem is still present on first pageload. I'll go on looking for the problem.

#13 Updated by Karsten Dambekalns about 10 years ago

  • Status changed from New to Resolved
  • Assignee changed from Christian Jul Jensen to Karsten Dambekalns
  • % Done changed from 0 to 100

Since the resize stuff is gone, this is solved.

Also available in: Atom PDF