Bug #19697

enableWordClean on pasting does not work, if hidden button is not in showButtons and/or toolbarOrder

Added by Chris topher about 11 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Should have
Category:
RTE (rtehtmlarea + ckeditor)
Target version:
-
Start date:
2008-12-14
Due date:
% Done:

0%

TYPO3 Version:
7
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Quoting what Stan wrote to me via email:

I found that there is a bug in the RTE configuration processing: if hidden button "cleanword" is not present in the showButtons and/or the toolbarOrder properties, the feature is not enabled. Perhaps the bug was introduced in TYPO3 4.2.0

As a workaround, I added the following two lines in PageTSConfig
RTE.default.showButtons := addToList(cleanword)
RTE.default.toolbarOrder := addToList(cleanword)
No additional button will actually appear in the toolbar, but the feature will be enabled.

The feature uses an hidden button that must be added to the toolbar by the configuration script.
(issue imported from #M9935)

rtehtmlarea_bugfix_9935.patch View (4.2 KB) Administrator Admin, 2009-01-20 05:10

History

#1 Updated by Stanislas Rolland about 11 years ago

Committed to SVN TYPO3core branch TYPO3_4-2 (revision 4759), for inclusion in TYPO3 4.2.4 and trunk (revision 4760).

#2 Updated by Felix Nagel over 8 years ago

I assume this bug was reintroduced as I need to add cleanword to make enableWordClean working. Could somebody please confirm? Tested with TYPO3 4.5.6

#3 Updated by Christian Ducrot over 6 years ago

This bug still exists in TYPO 6.1.1 and the workaround with cleanword also works.

#4 Updated by Chris topher over 6 years ago

  • Status changed from Resolved to New
  • Target version deleted (0)
  • TYPO3 Version set to 6.1

#5 Updated by Mathias Schreiber about 5 years ago

  • Category set to RTE (rtehtmlarea + ckeditor)
  • Is Regression set to No

#6 Updated by Riccardo De Contardi over 4 years ago

  • TYPO3 Version changed from 6.1 to 7

#7 Updated by christian rauch almost 4 years ago

I can confirm that this Bug is still present in Typo3 Version 7 LTS. It doesn't have to be in showButtons, but if it's missing in toolbarOrder it doesn't work. I think this one took me like 6 hours to figure out because it's also nowhere mentionend in the docs and basic cleaning works also without a request to htmlparser.

#8 Updated by Mathias Schreiber over 2 years ago

  • Status changed from New to Closed

HTMLArea is no longer supported by TYPO3.
You can open up new issues here https://github.com/FriendsOfTYPO3/rtehtmlarea.

Cheers
Mathias

Also available in: Atom PDF