Bug #21128

BE_USER object is cleared with assigning an empty string

Added by Oliver Hader over 11 years ago. Updated over 10 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
-
Target version:
-
Start date:
2009-09-23
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.3
PHP Version:
5.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

BE_USER object is cleared with assigning an empty string - thus, when you use isset($BE_USER) and expect a proper object, one will run into a fatal error since it's just a string.

(issue imported from #M12042)


Files

0012042.patch (1.41 KB) 0012042.patch Administrator Admin, 2009-09-23 01:09
#1

Updated by Oliver Hader over 11 years ago

Committed to SVN Trunk (rev. 6036)

Also available in: Atom PDF