Bug #2115

Base href is not correct when calling index_dev.php

Added by Christoph Blömer about 13 years ago. Updated about 11 years ago.

Status:
Resolved
Priority:
Must have
Category:
Resource
Target version:
-
Start date:
2008-11-11
Due date:
% Done:

100%

Estimated time:
PHP Version:
Has patch:
Complexity:

Description

The base href looks like:

Resources/Web/FLOW3/Public/MVC/http://192.168.149.129/

But it should be:

http://192.168.149.129/

#1

Updated by Karsten Dambekalns about 13 years ago

  • Status changed from New to Accepted
  • Assignee changed from Robert Lemke to Karsten Dambekalns
This is caused by interaction between relative link prefixing in the resource manager and marker replacement later on. This is what happens:
  1. base href="###BASEURI###" is transformed to
  2. base href="Resources/Web/FLOW3/Public/MVC/###BASEURI###" because URIs starting with a hash are considered relative
  3. Then the marker is replaced with the base URI, leading to base href="Resources/Web/FLOW3/Public/MVC/http://192.168.149.129/"
    Solution: never ever directly prefix markers.
#2

Updated by Karsten Dambekalns about 13 years ago

Better solution: never ever prefix URIs starting with a hash.

#3

Updated by Karsten Dambekalns about 13 years ago

  • Status changed from Accepted to Resolved
  • % Done changed from 0 to 100

Applied in changeset r1480.

Also available in: Atom PDF