Bug #22586

Compressor for JS causes PHP Warnings on Windows: filesize() and filemtime(): stat failed for t3lib/js/extjs/ux/flashmessages.js

Added by Chris topher over 10 years ago. Updated over 9 years ago.

Status:
Closed
Priority:
Should have
Category:
-
Target version:
-
Start date:
2010-05-04
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.4
PHP Version:
5.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

When I clear the cache and then call a page in the BE I get the following errors. They always appear both:

Core: Error handler (BE): PHP Warning: filesize(): stat failed for C:/htdocs/t3lib/js/extjs/ux/flashmessages.js in C:\htdocs\t3lib\class.t3lib_compressor.php line 302

Core: Error handler (BE): PHP Warning: filemtime(): stat failed for C:/htdocs/t3lib/js/extjs/ux/flashmessages.js in C:\htdocs\t3lib\class.t3lib_compressor.php line 302

After that I can call pages in the BE as I wish; I only get the error again after clearing the cache.

I do not get this error using a *nix server.
(issue imported from #M14303)


Files

bug_14303.diff (2.21 KB) bug_14303.diff Administrator Admin, 2010-11-29 09:36
bug_14303_v2.diff (3.22 KB) bug_14303_v2.diff Administrator Admin, 2010-11-29 12:04

Related issues

Related to TYPO3 Core - Bug #22546: Add a compressor/concatenator for CSS and JS to TYPO3ClosedSusanne Moog2010-04-29

Actions
Related to TYPO3 Core - Bug #22565: Improve t3lib_compressorClosedSteffen Kamper2010-05-02

Actions
Related to TYPO3 Core - Bug #25393: Fix path resolution in t3lib_compressor::compressCssFile()ClosedSteffen Gebert2011-03-25

Actions
#1

Updated by Rens Admiraal about 10 years ago

I had the same problem for files located in fileadmin/ which are configured in RTE.default.contentCSS
Supplied is a patch which fixes the problem that the t3lib_compressor class only handles files within the TYPO3 folder because it fails to create a valid path with this code:
substr($filename, strlen($GLOBALS['BACK_PATH']))

#2

Updated by Rens Admiraal about 10 years ago

After some testing the solution seemed to be more complex, created a new patch (v2)

#3

Updated by Steffen Kamper almost 10 years ago

committed v3 to trunk rev 9836

#4

Updated by Susanne Moog over 9 years ago

  • Target version deleted (4.5.0)

Also available in: Atom PDF