Bug #22954

No thumbnails are shown in the BE

Added by Chris topher about 9 years ago. Updated 11 months ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
-
Target version:
-
Start date:
2010-06-21
Due date:
% Done:

0%

TYPO3 Version:
4.3
PHP Version:
5.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

I just realized that I don't see any thumbnails in the BE (e.g. in filelist, in Web > Page or in image content elements). Recently this still worked...

I cleared the image cache in typo3temp/pics and the thumbnails for the frontend are regenerated and displayed in the FE correctly.
But in the BE I don't see any thumbnail.

I use
gm 1.1.10 and
convert/composite/identifiy 6.5.2-9.

This is recognized in the Install Tool. The test images there render correctly.

(issue imported from #M14811)

History

#1 Updated by Chris topher about 9 years ago

I just remember that I recently changed the affected project to use utf-8. Don't know, if that could influence this bug...

#2 Updated by Chris topher about 9 years ago

I just investigated this a bit further:
When changing to utf-8 I also converted the Configuration files like localconf.php and realurl_conf.php to utf-8. My editor silently added a byte order mark at the beginning of the files.

When a thumbnail should be shown, thumbs.php is called. This then calls config_default.php which then calls localconf.php and realurl_conf.php. These files returned the byte order mark in the outputbuffer.
Finally this screwed up the header of the returned image file.

Converting the files back to ANSI solved the issue.

#3 Updated by Chris topher about 9 years ago

Resolved, no change required.

#4 Updated by Benni Mack 11 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF