Bug #23272

Incorrect backpath used when including default and skin stylesheets

Added by Jeff Segars almost 11 years ago. Updated over 7 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2010-07-26
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.5
PHP Version:
5.3
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

CSS paths in typo3/template.php are currently calculated using $GLOBALS['BACK_PATH']. Elsewhere in t3lib_tceforms, $this->backPath is used instead of $GLOBALS['BACK_PATH]. $GLOBALS['BACK_PATH'] may not be available in all contexts, leading to missing styles.

The issue can easily be seen in frontend editing, where the CSS for sprite images is not loaded due to the incorrect path. In this instance $this->backPath is set properly and used elsewhere in t3lib_tceforms but $GLOBALS['BACK_PATH'] is not.

In previous versions of TYPO3, $this->backPath was not set at all in the backend context because all of the views were directly inside /typo3/ and no back path was needed. After moving list view and other modules to extensions, a back path is needed so the first hunk in this patch sets $this->backPath to $GLOBALS['BACK_PATH'] in the normal backend context. While its related to this patch, it could also be a followup to RFCs 15149-15155.

(issue imported from #M15242)


Files

15242.diff (1.93 KB) 15242.diff Administrator Admin, 2010-07-26 22:51
15242_v2.diff (2.17 KB) 15242_v2.diff Administrator Admin, 2010-07-27 18:14

Also available in: Atom PDF