Bug #23354

Switch-back user mode: Login refresh problem

Added by Lorenz Ulrich over 10 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Backend User Interface
Target version:
-
Start date:
2010-08-04
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
8
PHP Version:
7.0
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

When you're logged in as an admin and switch to another backend user in switch-back mode, TYPO3 asks for the password of this user once the login must be refreshed. So the only possibility is to log out and login again as you normally don't know every user's password.

(issue imported from #M15356)


Files

switchback-user-relogin-44.jpg (35.9 KB) switchback-user-relogin-44.jpg Administrator Admin, 2010-08-06 00:20
#1

Updated by Oliver Hader over 10 years ago

Can you please provide the exact version of TYPO3 you used to have that behaviour? Did it work in a previous version or in other words "is it another regression"?

#2

Updated by over 10 years ago

It's no regression as far as I can tell.

In TYPO3 <= 4.3 once the session has expired there is a popup window allowing relogin. If I logged in as "admin" and changed to user "editor" in switch-back mode, the popup suggests "editor" as username. But there I can change username to "admin" and enter the admin password and so I stay logged in.

In TYPO3 4.4+ login refresh is done by ExtJS. Now if I am logged in as "admin" and change to user "editor" in switch-back mode, the popup doesn't let me choose the username (see screenshot), so as I don't know the password from user "editor", I cannot stay logged in.

#3

Updated by Alexander Opitz about 7 years ago

  • Category set to Backend User Interface
  • Target version deleted (0)
  • Is Regression set to No
#4

Updated by Mathias Schreiber almost 6 years ago

  • Target version set to 7.4 (Backend)

I'm targetting this one for 7.4, but still I'm not sure if there is something to fix.
Switching into a user is a temporary action and thus should not do magic of some sorts.

#5

Updated by Riccardo De Contardi over 5 years ago

still present in both 6.2.14 and 7.4 (latest master)

#6

Updated by Susanne Moog over 5 years ago

  • Target version changed from 7.4 (Backend) to 7.5
#7

Updated by Benni Mack over 5 years ago

  • Target version changed from 7.5 to 7 LTS
#8

Updated by Mathias Schreiber about 5 years ago

  • Target version deleted (7 LTS)
#9

Updated by Riccardo De Contardi almost 4 years ago

Still present on 8.7-dev (latest master)

#10

Updated by Josef Glatz about 3 years ago

  • TYPO3 Version changed from 4.4 to 8
  • PHP Version changed from 5.2 to 7.0

can confirm, therefore update issue versions

#11

Updated by Christian Kuhn about 3 years ago

  • Status changed from New to Closed

since 'switch to user' is meant as a temporary test from an admin side, and with the default session timeout being increased to many more hours meanwhile, i don't consider this issue to me relevant to be solved anymore at the moment. i'll close it for now. please feel free to re-open the issue with more description on a possible solution for at least core version v9 if you still feel this should be tackled.

Also available in: Atom PDF