Bug #24294

Live-Search: Searching with deactivated List Module gives JS Error: [string] web_list was not found in modules

Added by Chris topher about 9 years ago. Updated almost 9 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
-
Target version:
-
Start date:
2010-12-05
Due date:
% Done:

0%

TYPO3 Version:
4.5
PHP Version:
5.3
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Using a BE User, who does not have access to the List Module, you get the following error when you click on a search result to open it:

[string] web_list was not found in modules

(issue imported from #M16680)

16680.diff View (1.56 KB) Administrator Admin, 2011-01-18 23:10


Related issues

Related to TYPO3 Core - Feature #24092: Add live search to the backend toolbar Closed 2010-11-17

History

#1 Updated by Jeff Segars about 9 years ago

Hmm, do you happen to know offhand how 4.4 handles this situation? The only thing I can think of is only showing the top hits in the Live Search without a button linking to list view.

#2 Updated by Jeff Segars about 9 years ago

Just double checked 4.4 and the old search reloads the entire backend in the inside the frame where list view should be. There's definitely not a precedent to follow :)

#3 Updated by Steffen Kamper about 9 years ago

This inconsistence exists since years. imho it's wrong to use list module for search. There should be an own module "be_search" that simply extend t3lib_ recordlist and show search results. It's normal usecase that you want to restrict a user without listvview, but don't restrict him on search.

Consequent for now would be to show search box only when list ext is installed.

#4 Updated by Chris topher about 9 years ago

If the list module is deactivated, you can still search for the pid of a page. But basically everything else does not work.

If the user searched for something not prepended with "#page:", then a possibility would be to output a message telling the user, that the search needs the list module and that he therefore cannot really use the search. But I think that, if you deactivated that module, you did that, because you want that module to be deactivated. People won't activate it, because the search needs it. So basically such a message would only tell you that there is a great function, which you cannot use.
We should not do that; that is bad.

So after all I think Steffen's idea to only show the search, when the list module is activated sounds good.

#5 Updated by Jeff Segars about 9 years ago

Attached patch checks the user permissions for the list module and only adds live search when the list module is available.

I'll get this on the core list tomorrow, but any testing in the meantime would be appreciated.

#6 Updated by Chris topher about 9 years ago

Hi Jeff,

thank you for the patch! It works as advertised! :-)

#7 Updated by Jeff Segars about 9 years ago

Thanks for the quick test. It's on the core list now.

#8 Updated by Jeff Segars about 9 years ago

Committed to trunk in r10252.

#9 Updated by Susanne Moog almost 9 years ago

  • Target version deleted (4.5.0)

Also available in: Atom PDF