Bug #2486

Template names not resolved correctly (file name case issue)

Added by Karsten Dambekalns over 12 years ago. Updated almost 11 years ago.

Status:
Resolved
Priority:
Must have
Category:
-
Target version:
-
Start date:
2009-01-20
Due date:
% Done:

0%

Estimated time:
Has patch:

Description

In r1769 I tried to fix a bug which I experienced, in r1773 I reverted the case-change to the template file names. Now, here is what the problem is:

When you call the XSD generation helper, you simply call http://.../fluid

  1. Since no controller and action is given, "Default" and "index" are used
  2. The template is resolved as ".../Default/index.html", fine.

Now you fill in the form and press proceed.

  1. Controller and action are given, "default" and "generatexsd" are used
  2. The template is resolved as ".../default/generatexsd.html"
  3. The file lies in ".../Default/generateXSD.html" and cannot be found, leading to Exception 1225709595

The FLOW3 MVC part circumvents the problem by using getCaseSensitiveObjectName() when looking for controller or view objects. Since the template is not registered with the object manager, this is of no help here, but a similar mechanism is needed.

Note: The problem can only be reproduced on a case-sensitive filesystem.

#1

Updated by Sebastian Kurfuerst over 12 years ago

Resolved. The rule is now as follows:

- All templates are in the folder Resources/Private/Templates/<ControllerName>/<actionname>.html, where
- ControllerName is exactly spelled like the class
- actionname is lowercased.

#2

Updated by Sebastian Kurfuerst over 12 years ago

  • Status changed from New to Resolved
  • Assignee set to Sebastian Kurfuerst

Also available in: Atom PDF