Bug #25448

Use of undefined constant 'X' during prototype injection

Added by Karsten Dambekalns over 10 years ago. Updated over 10 years ago.

Status:
Closed
Priority:
Must have
Assignee:
Category:
Object
Target version:
-
Start date:
2011-03-30
Due date:
% Done:

0%

Estimated time:
PHP Version:
Has patch:
Complexity:

Description

When a prototype is needed for DI but has constructor arguments (that can be created through a factory), everything could be fine. But since ProxyClassBuilder, line 398, contains only unfinished code, the proxy class contains code like

    /**
     * Autogenerated Proxy Method
     */
    public function FLOW3_Proxy_injectProperties() {
        $this->mailer = new \F3\SwiftMailer\Mailer(X));
    }

This then leads to exceptions in FLOW3 because PHP produces a notice: Use of undefined constant X - assumed 'X' in .../Data/Temporary/902451e70049/StaticObjectContainer.php line ...

One way to reproduce this is to try and use SwiftMailer.


Related issues

Related to TYPO3.Flow - Bug #10595: ObjectManager should not allow injection of prototypesRejectedRobert Lemke2010-11-02

Actions
Has duplicate TYPO3.Flow - Bug #25908: ProxyClassBuilder produces invalid code for prototype argumentsResolvedRobert Lemke2011-04-12

Actions
#1

Updated by Karsten Dambekalns over 10 years ago

  • Status changed from New to Closed

Duplicate with nicer description provided by Bastian :)

Also available in: Atom PDF