Feature #27115

AOP should provide a way to change method parameters

Added by Fernando Arconada about 10 years ago. Updated almost 10 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
AOP
Target version:
-
Start date:
2011-05-29
Due date:
% Done:

0%

Estimated time:
PHP Version:
Has patch:
Complexity:

Description

Actually even with @around you cant change the called method arguments. There is a getArguments in the joinpoint but there isnt any setArguments, actually you can only change the returned value.


Related issues

Is duplicate of TYPO3.Flow - Feature #29514: AOP advices should be able to change method argumentsResolvedAndreas Förthner2011-09-06

Actions

Also available in: Atom PDF