Task #27629

Story #12690: As an administrator I can set up the conference base data

Adjust Models to enable editing

Added by Bastian Waidelich over 10 years ago. Updated over 10 years ago.

Status:
Resolved
Priority:
Should have
Target version:
Start date:
2011-06-21
Due date:
% Done:

100%

Estimated time:

Description

Currently we're using the @Id annotation in the models Circular, IntermissionType, Location, Room and SessionType to mark the title/subject as identity.
This leads to the fact that those can't be edited anymore (see #13324)

The Id annotations should be removed so that FLOW3 introduces the flow3_persistence_identifier

Note: To be able to migrate the database on the live server, a doctrine migration must be provided.


Files

Version20110621193235.php (10.4 KB) Version20110621193235.php Doctrine Migration Bastian Waidelich, 2011-06-21 19:48

Related issues

Related to TYPO3.Flow - Bug #13324: It's not possible to update entities without repositoryResolvedKarsten Dambekalns2011-02-24

Actions
#1

Updated by Mr. Hudson over 10 years ago

Patch set 1 of change Iff50f6ac0dcf272d9140e11e976d2bd0d41072e2 has been pushed to the review server.
It is available at http://review.typo3.org/2866

#2

Updated by Bastian Waidelich over 10 years ago

By changing the models as described above and calling flow3_dev flow3:doctrine:migrationdiff I get following exception:

Uncaught Exception in FLOW3 SQLSTATE[HY000]: General error: 1005 Can't create table 't3con11.#sql-3d4_ba' (errno: 150) thrown in file C:\Users\bwaidelich\_HTDOCS\t3con11\Packages\Framework\FLOW3\Resources\PHP\Doctrine\DBAL\Connection.php in line 577

Doctrine creates a migration anyways (see attachment) but calling flow3:doctrine:update throws a similar exception:

Uncaught Exception in FLOW3 SQLSTATE[HY000]: General error: 1005 Can't create table 't3con11.#sql-3d4_ca' (errno: 150) thrown in file C:\Users\bwaidelich\_HTDOCS\t3con11\Packages Framework\FLOW3\Resources\PHP\Doctrine\DBAL\Connection.php in line 577

#3

Updated by Karsten Dambekalns over 10 years ago

Caused by a foreign key constraint violation, can probably be solved by adjusting the migration. I'll check.

#4

Updated by Mr. Hudson over 10 years ago

Patch set 2 of change Iff50f6ac0dcf272d9140e11e976d2bd0d41072e2 has been pushed to the review server.
It is available at http://review.typo3.org/2866

#5

Updated by Karsten Dambekalns over 10 years ago

  • % Done changed from 0 to 90

The change works now, but the down migration needs to be made working. I'm at it...

#6

Updated by Mr. Hudson over 10 years ago

Patch set 3 of change Iff50f6ac0dcf272d9140e11e976d2bd0d41072e2 has been pushed to the review server.
It is available at http://review.typo3.org/2866

#7

Updated by Bastian Waidelich over 10 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 90 to 100

Also available in: Atom PDF