Bug #27919

Preview in Admin Panel does not handle Timezone correctly

Added by Webadmin no-lastname-given about 10 years ago. Updated over 4 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Backend User Interface
Target version:
-
Start date:
2011-07-06
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.5
PHP Version:
5.3
Tags:
Datetime
Complexity:
Is Regression:
No
Sprint Focus:

Description

If you have enabled a more finer timing (starttime/endtime with the possibility to enter minutes instead of only days) of content elements you are not able to preview this. Here in Germany there will be always a time difference of 2 hours.

For example: An element should appear at 10:00, you will see ist also when you enter 09:00 in the admin panel. Only on times < 08:00 it will be hidden.


Related issues

Related to TYPO3 Core - Feature #61110: Support for timezones in all date fields in TYPO3 BENew2014-08-21

Actions
Related to TYPO3 Core - Bug #66793: "simulate time" in admin-panel does not respect timezoneClosed2015-05-05

Actions
#1

Updated by Oliver Hader about 10 years ago

  • Target version changed from 4.5.4 to 4.5.6
#2

Updated by Chris topher almost 10 years ago

  • Target version changed from 4.5.6 to 4.5.8
#3

Updated by Ernesto Baschny over 9 years ago

  • Target version changed from 4.5.8 to 4.5.12
#4

Updated by Christoph Moeller over 8 years ago

Is there any action going on in t3lib/jsfunc.evalfield.js? Does not seem so, according to the git commit log in the 6.x branch (at least not concerning the date logic, just CGL etc.). We had a look at it and most of it is Kasper-Code from 2001 - no offense, JS just wasn't ready, back then ;-)

We have a "hotfix" available that fixes at least the time offset when previewing elements/pages that have a date+time (instead of just date) start date set. It's clearly a dirty hack (parses, corrects and replaces the given date string to get the desired result), but it solves the problem for us for now. It's available at https://gist.github.com/b54bd38fe7bb6608490a. Add the Javascript snippet to the frontend output if a BE user is logged in (by a TS condition or whatever) and you should be all set.

We do not have the resources/budget to go over t3lib/jsfunc.evalfield.js - but this piece of code definitely needs some love and care or better: a rewrite. Any takers here? We might add in some sponsoring in terms of money or knowhow/explanation/help.

#5

Updated by Nikola Stojiljković about 7 years ago

  • Target version changed from 4.5.12 to 7.0

13 years later, the code still looks the same. I will try to refactor it since we need to add support for timezone rendering in the datetime field.

#6

Updated by Nikola Stojiljković about 7 years ago

Christoph Moeller wrote:

Is there any action going on in t3lib/jsfunc.evalfield.js? Does not seem so, according to the git commit log in the 6.x branch (at least not concerning the date logic, just CGL etc.). We had a look at it and most of it is Kasper-Code from 2001 - no offense, JS just wasn't ready, back then ;-)

Please take a look at https://review.typo3.org/#/c/32360/.

#7

Updated by Mathias Schreiber almost 7 years ago

  • Target version changed from 7.0 to 7.1 (Cleanup)
#8

Updated by Benni Mack over 6 years ago

  • Target version changed from 7.1 (Cleanup) to 7.2 (Frontend)
  • Is Regression set to No
#9

Updated by Benni Mack over 6 years ago

  • Target version changed from 7.2 (Frontend) to 7.4 (Backend)
#10

Updated by Susanne Moog about 6 years ago

  • Target version changed from 7.4 (Backend) to 7.5
#11

Updated by Benni Mack about 6 years ago

  • Target version changed from 7.5 to 7 LTS
#12

Updated by Mathias Schreiber almost 6 years ago

  • Target version deleted (7 LTS)
  • Tags set to Datetime
#13

Updated by Oliver Hader about 5 years ago

  • Parent task set to #77562
#14

Updated by Riccardo De Contardi over 4 years ago

  • Related to Bug #66793: "simulate time" in admin-panel does not respect timezone added
#15

Updated by Riccardo De Contardi over 4 years ago

  • Status changed from New to Closed

I close this issue in favor of #66793 please continue the discussion there. Thank you.

If you think that this is the wrong decision, then please reopen the issue or open a new issue with a reference to this one.

#16

Updated by Markus Klein over 4 years ago

  • Parent task deleted (#77562)

Also available in: Atom PDF