Feature #28137

Do not use clone in PersistentObject ParamConverter

Added by Benjamin Eberlei over 10 years ago. Updated about 10 years ago.

Status:
Closed
Priority:
Should have
Category:
Persistence
Start date:
2011-07-13
Due date:
2011-07-13
% Done:

100%

Estimated time:
PHP Version:
Has patch:
Complexity:

Description

Currently clone is used inside the PersistentObject ParamConverter and objects have to be merged back into persistence context (in case of doctrine) using $em->merge(). This creates unnecessary performance problems where the state of an object is first moved into a new object, then moved back into the persistent object.

This is a dependency of the previous transaction ticket, since cloning is currently necessary with transactions always being flushed to the database.


Related issues

Is duplicate of TYPO3.Flow - Task #29039: Change default policy for Doctrine to DEFERRED_EXPLICITResolvedKarsten Dambekalns2011-08-17

Actions
Follows TYPO3.Flow - Feature #28136: HTTP Semantics for Transactions and moreNew2011-07-12

Actions
#1

Updated by Karsten Dambekalns about 10 years ago

  • Project changed from TYPO3 Flow Base Distribution to TYPO3.Flow
#2

Updated by Karsten Dambekalns about 10 years ago

  • Category set to Persistence
  • Status changed from New to Closed
  • Assignee set to Karsten Dambekalns
  • Target version set to 1.0 beta 1
  • % Done changed from 0 to 100

Resolved by duplicate issue #29039.

Also available in: Atom PDF