Bug #28138

ReflectionService Cache should be case insensitive

Added by Bastian Waidelich over 10 years ago. Updated over 10 years ago.

Status:
Rejected
Priority:
Should have
Assignee:
Category:
Reflection
Target version:
-
Start date:
2011-07-12
Due date:
% Done:

0%

Estimated time:
PHP Version:
Has patch:
Complexity:

Description

Currently ReflectionService stores reflected classes and methods in the firstLevel Cache by referring to the correctly cased class/method name.
This should be changed to always use lowercased cache identifiers in order to make ReflectionService work for classes/methods where the case is not known (e.g. CommandController).

#1

Updated by Bastian Waidelich over 10 years ago

  • Status changed from New to Rejected
  • Target version deleted (1.0 beta 1)

After thinking about it again and discussing it with other team members I'm not sure anymore, whether ReflectionService should really be changed to handle wrong cased method/class names. Especially as the built-in Reflection of PHP does not seem to support it in every case (class names are expected correctly cased sometimes).
For the above mentioned CommandController, the issue is already solved with #28172

Also available in: Atom PDF