Bug #28235

t3lib_div::int_from_version not usable in ext_autoload.php

Added by Björn Pedersen over 10 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2011-07-15
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.6
PHP Version:
Tags:
Complexity:
hard
Is Regression:
Sprint Focus:

Description

This cause ext additional_reports to crash TYPO3.

I am not sure wether this is a bug in Core or in the ext. In the second case it should get documented.


Related issues

Related to TYPO3 Core - Feature #28063: Use caching framework in autoloaderClosed2011-07-10

Actions
#1

Updated by Björn Pedersen over 10 years ago

One possible solution would be to do a two-step autoload setup:
First setup core autoload and then append ext_autoload.php data in a second step.

#2

Updated by Tolleiv Nietsch over 10 years ago

  • Status changed from New to Needs Feedback

How is that not a duplicate of #28236 ?

#3

Updated by Tolleiv Nietsch over 10 years ago

  • Status changed from Needs Feedback to Accepted
  • Complexity set to hard

Ah never mind - assumption is right.

#4

Updated by Christian Kuhn almost 9 years ago

  • Status changed from Accepted to Resolved

Resolved, won't fix: There must be no logic in ext_autoload, it must only return some array and shouldn't do any additional logic!

#5

Updated by Benni Mack over 3 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF