Bug #28972

(v5) Bug in new caching mechanism

Added by Peter Beernink over 10 years ago. Updated over 10 years ago.

Status:
Resolved
Priority:
Must have
Category:
Core
Start date:
2011-08-14
Due date:
% Done:

100%

Estimated time:
Has patch:
No

Description

After creating a fresh clone of the FLOW3 base distribution, I encountered the following behaviour.
When you run the FLOW3 Welcome package for the first time, everything works as expected however, when you refresh the page, all styling is gone.

It turned out that the HTML output is missing all code between the <f:base> and the first variable, {version} in this case.
Doing some further checking, that whole block is missing from the cached PHP code in the Cache/Code/Fluid_TemplateCache/...html file

Although I've tested this in v5, it might as well be also an issue in v4.

#1

Updated by Bastian Waidelich over 10 years ago

  • Assignee set to Bastian Waidelich

I'll look into this. Thanks for reporting!

#2

Updated by Bastian Waidelich over 10 years ago

  • Status changed from New to Accepted
  • Assignee changed from Bastian Waidelich to Sebastian Kurfuerst

I can reproduce the issue and the problem seems to be the Resource Interceptor that wraps the uri.resource ViewHelper around text nodes to fix relative URIs.

The good news: It's not a problem of the compiling process itself and it won't affect v4!

Sebastian Kurfuerst I assign this to you so you'll notice - I currently don't have enough time to dig deeper into this.

#3

Updated by Bastian Waidelich over 10 years ago

Bastian Waidelich wrote:

One more note:

The good news: It's not a problem of the compiling process itself [...]

That's prohbably not entirly true:
The resource Interceptor adds child nodes to a TextNode - that seems to be not supported by TemplateCompiler::convertTextNode()

#4

Updated by Sebastian Kurfuerst over 10 years ago

thanks! I'll investigate this further.

#5

Updated by Mr. Hudson over 10 years ago

Patch set 1 of change If63b3ff19ea9af433c042d06fc724cbab3987f42 has been pushed to the review server.
It is available at http://review.typo3.org/4349

#6

Updated by Sebastian Kurfuerst over 10 years ago

  • Status changed from Accepted to Under Review
  • % Done changed from 0 to 100
#7

Updated by Sebastian Kurfuerst over 10 years ago

  • Status changed from Under Review to Resolved

Also available in: Atom PDF