Bug #29045

Wakeup of Query sets wrong state if originally no constraint has been set

Added by Ferdinand Kuhl almost 11 years ago. Updated almost 11 years ago.

Status:
Resolved
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2011-08-17
Due date:
% Done:

0%

Estimated time:

Description

If I save a Query-Result in a WidgetController and afterwards call $result->getQuery->execute() I receive an empty result, because of the try-catch block around the execute call which simply returns an empty result in case of an exception.

The problem seems to be in the __wakeup() method of \TYPO3\FLOW3\Persistence\Doctrine\Query

    public function __wakeup() {
        $this->queryBuilder->where($this->constraint);

everything works fine, if I inject a condition like this:

    public function __wakeup() {
        if ($this->constraint)
            $this->queryBuilder->where($this->constraint);

Related issues

Is duplicate of TYPO3.Flow - Bug #28995: Deferred Loading does not work with Doctrine QueryResultResolvedSebastian Kurfuerst2011-08-16

Actions

Also available in: Atom PDF