Feature #29065

HTML5 Custom Data Attributes

Added by Thomas Allmer about 10 years ago. Updated about 10 years ago.

Status:
Closed
Priority:
Could have
Category:
Core
Target version:
-
Start date:
2011-08-17
Due date:
% Done:

0%

Estimated time:
Has patch:
No

Description

Fluid should support the use of HTML5 Custom Data Attributes as described in the W3C Specification1.

The Patterns need to be changed so that attributes with "-" are actually identified as such. Currently fluid breaks with such attributes.
Furthermore "data-*" won't fit into the current way of registering attributes with a full name and type. Fluid will probably need a solution which allows a registration of patterns for attributes. (always with string as type?)

[1]: http://dev.w3.org/html5/spec/elements.html#embedding-custom-non-visible-data-with-the-data-attributes


Related issues

Is duplicate of TYPO3.Fluid - Bug #26394: Form Viewhelper does not work with html5 custom data attributesRejected2011-04-28

Actions
#1

Updated by Bastian Waidelich about 10 years ago

  • Status changed from New to Closed
  • Priority changed from Must have to Could have

Closing as duplicate of #26394

Also available in: Atom PDF