Bug #29295

Uncaught Exception in FLOW3 SQLSTATE[HY000]: General error: 1005 Can't create table 'phoenix.#sql-3dc_28' (errno: 150)

Added by Hari K T almost 10 years ago. Updated over 9 years ago.

Status:
Closed
Priority:
-- undefined --
Category:
Persistence
Target version:
-
Start date:
2011-08-27
Due date:
% Done:

0%

Estimated time:
PHP Version:
Has patch:
No
Complexity:

Description

Hi ,

I was trying the Blog Tutorial . As I was not having the cheat sheet , at some point I downloaded the Blog Package from the git .

I did a migration and it throws the below errors . Is it a bug ?


hari@hari-Vostro1510:/media/Linux/flow3$ ./flow3 doctrine:migrate

Uncaught Exception in FLOW3 SQLSTATE[HY000]: General error: 1005 Can't create table 'phoenix.#sql-3dc_28' (errno: 150)
thrown in file Packages/Framework/Doctrine/Classes/DBAL/Connection.php
in line 618

#0 TYPO3\FLOW3\Error\DebugExceptionHandler::echoExceptionCli()
   /media/Linux/flow3/Packages/Framework/TYPO3.FLOW3/Classes/Error/AbstractExceptionHandler.php:60

#1 TYPO3\FLOW3\Error\AbstractExceptionHandler::handleException()

hari@hari-Vostro1510:/media/Linux/flow3$ 
#1

Updated by Karsten Dambekalns almost 10 years ago

  • Category changed from - Error Handler Report - to Persistence
#2

Updated by Andreas Förthner almost 10 years ago

If I remember correctly, this error occures whith wrong relations, i.e. if wrong foreign keys are about to be created...

#3

Updated by Christian Müller almost 10 years ago

Indeed there was a fix recently, could you try if you can reproduce the error with current master? Because I guess not then we could close the ticket.

#5

Updated by Karsten Dambekalns over 9 years ago

  • Status changed from New to Closed
  • Has patch set to No

This hints at some something being wrong with either the database or the migration. Hard to tell, but I'll close this, as the migrations in FLOW3 and Blog work in general...

Also available in: Atom PDF