Task #29340

Check usage of hash_base.

Added by Björn Pedersen almost 11 years ago. Updated almost 4 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2011-08-30
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.6
PHP Version:
Tags:
Complexity:
Sprint Focus:

Description

While checking the use of hash_base in class.tslibfe.php, I found the $this->hash_base is only used in to set $this->config['hash_base'] in generatePage_preProcessing (with a comment that it is used for caching informational purposes). But a grep revealed no further usage of either var's. So maybe that could get deprecated and removed in the future.


Related issues

Is duplicate of TYPO3 Core - Task #53404: Page cache saves the hash_baseClosedAlexander Opitz2013-11-07

Actions
#1

Updated by Björn Pedersen almost 11 years ago

[9:14] webmaster@wwwtest % pwd
/home/webmaster/frm2/typo3_src_git
[9:14] webmaster@wwwtest % find . -name \*.php -print0 | xargs -0 grep hash_base
./typo3/sysext/cms/tslib/class.tslib_fe.php:    var $hash_base='';                    // Loaded with the serialized array that is used for generating a hashstring for the cache
./typo3/sysext/cms/tslib/class.tslib_fe.php:     * @return    string        MD5 hash of $this->hash_base which is a serialized version of there variables.
./typo3/sysext/cms/tslib/class.tslib_fe.php:        $this->hash_base = serialize(
./typo3/sysext/cms/tslib/class.tslib_fe.php:        return md5($this->hash_base);
./typo3/sysext/cms/tslib/class.tslib_fe.php:        $this->config['hash_base'] = $this->hash_base;    // For cache management informational purposes.

#2

Updated by Steffen Ritter over 10 years ago

  • Target version deleted (4.7.0)
#3

Updated by Alexander Opitz over 8 years ago

  • Status changed from New to Resolved
#4

Updated by Benni Mack almost 4 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF