Bug #29486

injectSettings() doesn't receive always the settings of its own package

Added by Robert Lemke about 8 years ago. Updated about 8 years ago.

Status:
Resolved
Priority:
Should have
Assignee:
Category:
Object
Start date:
2011-09-05
Due date:
% Done:

100%

PHP Version:
Has patch:
Complexity:

Description

injectSettings() should always receive the settings of that package the inject method is declared in. That is, we should derive the package key for the settings from the name of the class containing the injectSettings() method.

Currently this is not the case for settings injection defined in the Objects.yaml and referring to a different class (see related issue).


Related issues

Blocks TYPO3.Flow - Task #29412: Remove generic PDO backend Resolved 2011-09-01

Associated revisions

Revision c850b2a0 (diff)
Added by Robert Lemke about 8 years ago

[BUGFIX] Injected settings are now from the correct package

This fixes a bug caused by the Configuration Builder which resulted
in settings of a wrong package being injected into classes under
certain circumstances.

Change-Id: Id2c26e600efb6ac34733d42cc0e518526e583fee
Resolves: #29486

History

#1 Updated by Mr. Hudson about 8 years ago

  • Status changed from Accepted to Under Review

Patch set 1 of change Id2c26e600efb6ac34733d42cc0e518526e583fee has been pushed to the review server.
It is available at http://review.typo3.org/4774

#2 Updated by Robert Lemke about 8 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

Also available in: Atom PDF