Bug #30234

Compiled proxies override parent instance

Added by Christopher Hlubek about 10 years ago. Updated about 10 years ago.

Status:
Closed
Priority:
Should have
Category:
Object
Start date:
2011-09-23
Due date:
% Done:

0%

Estimated time:
PHP Version:
Has patch:
Complexity:

Description

A subclass of a singleton does override the parent instance in the object manager inside the constructor. See the functional test in the submitted patch for more information.


Related issues

Is duplicate of TYPO3.Flow - Bug #27810: ObjectManager returns Subclass sometimesClosedChristopher Hlubek2011-07-02

Actions
#1

Updated by Mr. Hudson about 10 years ago

  • Status changed from New to Under Review

Patch set 1 of change I00f25162b18f0b3a5e32a6241b6ef2ab6d066415 has been pushed to the review server.
It is available at http://review.typo3.org/5253

#2

Updated by Johannes K about 10 years ago

Looks like http://forge.typo3.org/issues/27810 is a duplicate of this bug

#3

Updated by Karsten Dambekalns about 10 years ago

  • Category set to Object
  • Target version set to 1.0.0
#4

Updated by Karsten Dambekalns about 10 years ago

  • Status changed from Under Review to Closed

Closed as duplicate of #30234.

#5

Updated by Johannes K about 10 years ago

Closed as duplicate of itself ;). Really?

Also available in: Atom PDF