Bug #30714

\TYPO3\FLOW3\var_dump() memory use causes fatal error debugging objects.

Added by Alexander Schnitzler almost 10 years ago. Updated over 8 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Error
Target version:
-
Start date:
2011-10-10
Due date:
% Done:

0%

Estimated time:
PHP Version:
Has patch:
No
Complexity:

Description

During some FLOW3 CRUD testing, I got an error several times I wanted to debug objects that have related objects.

Something like \TYPO3\FLOW3\var_dump(new SomeObject()) always worked, more complex object trees caused PHP run out of memory.

In my example (see attached picture) I just created a "new"-form to create a new Message-Object that has a User-Object related as the sender of the message. Yet the debugging of that simple thing failed.


Files

Unbenannt-1.png (20 KB) Unbenannt-1.png Alexander Schnitzler, 2011-10-10 12:04

Related issues

Is duplicate of TYPO3.Flow - Bug #44278: High memory consumption of Debugger::renderObjectDump() prevents display of ExceptionsResolvedKarsten Dambekalns2013-01-02

Actions
#1

Updated by Karsten Dambekalns almost 10 years ago

  • Project changed from TYPO3 Flow Base Distribution to TYPO3.Flow
#2

Updated by Karsten Dambekalns almost 10 years ago

  • Subject changed from \TYPO3\FLOW3\var_dump() causes fatal error debugging objects. to \TYPO3\FLOW3\var_dump() memory use causes fatal error debugging objects.
  • Category set to Error
  • Target version deleted (1230)
#4

Updated by Karsten Dambekalns over 8 years ago

  • Status changed from New to Closed
  • Has patch set to No

Duplicate of #44278

Also available in: Atom PDF