Task #32269

t3lib_DB debug_check_recordset for exec_SELECT_*

Added by Alexander Wahl over 10 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
Should have
Category:
Integration
Start date:
2011-12-02
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
6.2

Description

Syslog-Entries and or devlog-entries are written in function debug_check_recordset.

Altough functionality is already implemented, debug_check_recordset is not called from exec_SELECT-Querys because debug_check_recordset is called AFTER (!$this->sql_error()). So it never get's called.

So any error that occurs, will not be traced within debug_check_recordset. So this function at this point is usless.

Maybe providing a syslog entry within sql_error() would be a better approach because all sql-errors are then tracked within the syslog or errorlog.

Greetings
Alexander

#1

Updated by Michael Stucki over 10 years ago

  • Status changed from New to Needs Feedback

Hmm, we could easily replace the sql_error() call with the same debug_check_recordset() method. IMHO this should have the same effect, what do you think?

#2

Updated by Alexander Wahl over 10 years ago

yes. That whould be great. But in my opinion, besides the SQL-Error message the last query stored in debug_lastBuiltQuery should also be logged into devlog/syslog. This would save a lot of time.

Therefore storeLastBuiltQuery must be initially true.

At the moment, when an SQL-Error occurs in Extension, you have to edit the Extension to output the last SQL-Query to see where the problem is or developer has implemented his own error-catching mechanism.

So my feature request would be a more global approach to error logging. If something goes wrong, you only have to activate DEVLOG or SYSLOG and search the entries to find the bug.

#3

Updated by Alexander Opitz almost 9 years ago

Hi,

as this issue is very old. Does the problem still exists within newer versions of TYPO3 CMS (4.5 or 6.1)?

#4

Updated by Steffen Müller almost 9 years ago

  • Category set to Logging
  • Status changed from Needs Feedback to Accepted

Please leave this issue open. As soon as we start the Logging API integration in the core, this one will be covered as well.

#5

Updated by Steffen Müller almost 9 years ago

  • Tracker changed from Feature to Task
  • Project changed from TYPO3 Core to Logging Project
  • Category deleted (Logging)
  • Assignee set to Steffen Müller
#6

Updated by Steffen Müller almost 9 years ago

  • Category set to Integration
  • TYPO3 Version changed from 4.5 to 6.2
#7

Updated by Alexander Wahl almost 9 years ago

Alexander Opitz wrote:

Hi,

as this issue is very old. Does the problem still exists within newer versions of TYPO3 CMS (4.5 or 6.1)?

Hi Alexander,

not tested for 6.1. We are only working with LTS-Versions currently. Sorry.

#8

Updated by Steffen Müller over 6 years ago

  • Status changed from Accepted to Closed
  • translation missing: en.field_remaining_hours set to 0.0

This subproject is going to be closed. If you think this issue is still valid, please open a new issue in the core project.

Also available in: Atom PDF