Bug #33789

PersistentObjectConverter may break with < PHP 5.3.4

Added by Karsten Dambekalns over 9 years ago. Updated over 9 years ago.

Status:
Resolved
Priority:
Could have
Category:
Property
Start date:
2012-02-08
Due date:
% Done:

100%

Estimated time:
PHP Version:
Has patch:
No
Complexity:

Description

The use of newInstanceArgs() inside the PersistentObjectConverter breaks for PHP older than 5.3.4 if a class has no constructor (see https://bugs.php.net/52854).


Related issues

Related to TYPO3 Flow Base Distribution - Task #27770: Remove deprecated methods/classes for FLOW3 1.1ResolvedKarsten Dambekalns2011-06-29

Actions
#1

Updated by Karsten Dambekalns over 9 years ago

  • Target version changed from 1.0.3 to 1.1

Ok, this is indeed caused by https://review.typo3.org/5992

#2

Updated by Gerrit Code Review over 9 years ago

  • Status changed from Accepted to Under Review

Patch set 12 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/5992

#3

Updated by Gerrit Code Review over 9 years ago

Patch set 13 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/5992

#4

Updated by Gerrit Code Review over 9 years ago

Patch set 14 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/5992

#5

Updated by Karsten Dambekalns over 9 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

Also available in: Atom PDF