Bug #33968

Missing privileges to create symlinks in Windows cause exception

Added by Richard Lederer over 9 years ago. Updated about 9 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
Resource
Start date:
2012-02-16
Due date:
% Done:

0%

Estimated time:
PHP Version:
5.3
Has patch:
No
Complexity:

Description

Warning: symlink() [<a href='function.symlink'>function.symlink</a>]: Cannot create symlink, error code(1314) in C:\xampp\htdocs\FLOW3\Data\Temporary\Development\Cache\Code\FLOW3_Object_Classes\TYPO3_FLOW3_Resource_Publishing_FileSystemPublishingTarget_Original.php line 117
9 TYPO3\FLOW3\Error\ErrorHandler::handleError(2, "symlink() [<a href='function.symlink'>function.sym…link</a>]: Cannot create symlink, error code(1314)", "C:\xampp\htdocs\FLOW3\Data\Temporary\Development\C…Publishing_FileSystemPublishingTarget_Original.php", 117, array)

8 symlink("C:/xampp/htdocs/FLOW3/Packages/Framework/TYPO3.FLOW3/Resources/Public", "C:/xampp/htdocs/FLOW3/Web/_Resources/Static/Packages/TYPO3.FLOW3")

7 TYPO3\FLOW3\Resource\Publishing\FileSystemPublishingTarget_Original::publishStaticResources("C:/xampp/htdocs/FLOW3/Packages/Framework/TYPO3.FLOW3/Resources/Public/", "Packages/TYPO3.FLOW3/")

6 TYPO3\FLOW3\Resource\Publishing\ResourcePublisher_Original::publishStaticResources("C:/xampp/htdocs/FLOW3/Packages/Framework/TYPO3.FLOW3/Resources/Public/", "Packages/TYPO3.FLOW3/")

5 TYPO3\FLOW3\Resource\ResourceManager_Original::publishPublicPackageResources(array)

4 TYPO3\FLOW3\Core\Bootstrap::initializeResources()

3 TYPO3\FLOW3\Core\Bootstrap::initializeForRuntime()

2 TYPO3\FLOW3\Core\Bootstrap::handleWebRequest()

1 TYPO3\FLOW3\Core\Bootstrap::run()

Please include more helpful information!


Related issues

Related to TYPO3.Flow - Bug #35935: Symlinks still don't work reliably under WindowsClosedKarsten Dambekalns2012-04-13

Actions
Related to TYPO3.Flow - Task #11683: symlink() is not working on Windows XPResolvedRobert Lemke2010-12-24

Actions
#1

Updated by Karsten Dambekalns over 9 years ago

  • Category changed from - Error Handler Report - to Resource
  • Status changed from New to Needs Feedback
  • Assignee set to Rens Admiraal
  • Priority changed from Must have to Should have

Rens, could you take care of this? Yo are working on symlinks and Windows anyway, right?

The error is caused by the privileges needed to create symlinks in Windows are missing, from all I know:
#2

Updated by Karsten Dambekalns over 9 years ago

  • Subject changed from TYPO3\FLOW3\Error\Exception thrown in file ErrorHandler.php to Missing privileges to create symlinks in Windows cause exception
#3

Updated by Karsten Dambekalns over 9 years ago

  • Target version changed from 1.0.3 to 1.0.4
#4

Updated by Rens Admiraal over 9 years ago

Sure, will have a look at it.

@Richard: could you be so kind to add a note with the exact windows version you use?

#5

Updated by Gerrit Code Review over 9 years ago

  • Status changed from Needs Feedback to Under Review

Patch set 1 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/9528

#6

Updated by Gerrit Code Review over 9 years ago

Patch set 2 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/9528

#7

Updated by Gerrit Code Review over 9 years ago

Patch set 3 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/9528

#8

Updated by Gerrit Code Review over 9 years ago

Patch set 4 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/9528

#9

Updated by Karsten Dambekalns over 9 years ago

  • Target version changed from 1.0.4 to 1.0.5
#10

Updated by Karsten Dambekalns about 9 years ago

  • Status changed from Under Review to Closed

Also available in: Atom PDF