Bug #34324

Task #11969: Make widgets' template configurable

Template of widgets can't be changed

Added by Christian Müller almost 10 years ago. Updated almost 10 years ago.

Status:
Closed
Priority:
Must have
Category:
Widgets
Target version:
-
Start date:
2011-04-01
Due date:
% Done:

20%

Estimated time:
Has patch:
No

Description

Currently the widgets use the default template path only and it is impossible to override those which is kind of a nogo.

Attached patch fixes this. The path can be set via TS. e.g.

plugin.tx_fo.view.widgetRootPath = fileadmin/fo/

If using the pagination widget, the index.html needs to be at fileadmin/fo/ViewHelpers/Widget/Paginate/Index.html

One open question: Is this the correct way to go with the part "ViewHelpers" inside this path? or should it be fileadmin/fo/Paginate/Index.html?


Related issues

Is duplicate of TYPO3.Fluid - Bug #25695: Template of widgets can't be changedClosedChristian Müller2011-04-01

Actions
#1

Updated by Karsten Dambekalns almost 10 years ago

  • Category set to Widgets
  • Status changed from New to Closed
  • Assignee set to Karsten Dambekalns

Closing as duplicate of #25695

Also available in: Atom PDF