Bug #34408

CollectionValidator goes in endless recursion

Added by Pankaj Lele over 9 years ago. Updated over 9 years ago.

Status:
Closed
Priority:
Should have
Category:
Validation
Start date:
2012-02-29
Due date:
% Done:

0%

Estimated time:
PHP Version:
5.3
Has patch:
No
Complexity:

Description

This is a case when 2 domain objects are associated with ManyToMany relation. If the owning side object is created/updated/deleted via ActionController the page load hangs and after few minutes it goes out of memory.

I imagine Post m:n Tags, when Post is created the Post::tags property is validated with CollectionValidator then it again tries to validate Tag::posts property and goes in recursion.


Related issues

Is duplicate of TYPO3.Flow - Bug #34154: ObjectValidator has exponential growth factorResolvedRens Admiraal2012-02-21

Actions
#1

Updated by Karsten Dambekalns over 9 years ago

  • Status changed from New to Closed
  • Assignee set to Karsten Dambekalns

Duplicate of #34154 with fix under review at http://review.typo3.org/9180

Also available in: Atom PDF