Bug #34864

inproper escape of attribute names

Added by Nicholas Gray over 9 years ago. Updated over 9 years ago.

Status:
Rejected
Priority:
Must have
Category:
Persistence
Target version:
-
Start date:
2012-03-14
Due date:
% Done:

0%

Estimated time:
PHP Version:
Has patch:
No
Complexity:

Description

hi all,

I named an attribute "order" in my model and thus ran into problems running "./flow3 doctrine:update", since it was not escaped and then treated as MySQL command.

Here is the Error:

Uncaught Exception
SQLSTATE42000: Syntax error or access violation: 1064 You have an error
in your SQL syntax; check the manual that corresponds to your MySQL
server version for the right syntax to use near 'order position INT
DEFAULT NULL' at line 1


Related issues

Is duplicate of TYPO3.Flow - Bug #33639: Error in mySQL Statements with columnnames like "from" or "char"RejectedKarsten Dambekalns2012-02-02

Actions
#1

Updated by Karsten Dambekalns over 9 years ago

  • Project changed from TYPO3 Flow Base Distribution to TYPO3.Flow
#2

Updated by Karsten Dambekalns over 9 years ago

  • Category set to Persistence
  • Status changed from New to Rejected
  • Assignee set to Karsten Dambekalns
  • Has patch set to No

See #33639 for some information.

Also available in: Atom PDF