Feature #35

Refactor T3P_Core_AOPFramework: Extract build methods

Added by Robert Lemke over 14 years ago. Updated almost 11 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
AOP
Start date:
Due date:
% Done:

0%

Estimated time:
PHP Version:
Has patch:
Complexity:

Description

The T3P_Core_AOPFramework got a bit too large by the time and it makes sense extracting the whole proxy code building methods into its own class. While doing that, the code snippets should also be externalized and put into template files where it makes sense.

#1

Updated by Robert Lemke over 14 years ago

(In r159) * Core: Removed parsing support for "lifecycleDestructionMethod"
  • Reflection: Added doc tag parsing support for properties (created T3P_Reflection_Property)
  • Core: Implemented support for AOP Introduction declarations. Works, but needs a bit of a cleanup in T3P_Core_AOPFramework. Refs #35 and fixes #20.
#2

Updated by Robert Lemke over 14 years ago

(In r160) * Core: Refactored the T3P_Core_AOPFramework: The builder functions are now in their own class and have been consolidated. Still needs some cleanup in the method interceptor code generator. Addresses #35.

#3

Updated by Robert Lemke over 14 years ago

  • Status changed from New to Closed
  • Sprint set to fixed

Okay, I close this ticket for now - it's enough refactoring for the moment. If we feel like putting the code snippets into a template file, we can do so later on.

#4

Updated by Robert Lemke over 14 years ago

(In r167) Refactored the T3P_Core_AOPProxyClassBuilder:

  • Core: The AOPProxyClassBuilder smelled like Duplicated Code (76) and therefore I decided to split it up using the Template Method (325) pattern. Addresses #35.
  • Core: Added tests and fixtures to assert that introducing multiple interfaces does work (it didn't work as my tests showed soon). Now everything seems to be fine and that fixes #37.
#5

Updated by Karsten Dambekalns over 14 years ago

(In r169) Fixes failures in T3P_phpCRJackrabbit_CheckPermissionTest caused by incorrectly set up account permissions:
  • repository.xml now does no longer provide a default user for logins without credentials
  • The unit test base class uses the configured "anonymous" user for read-only session access
    This fixes #35

Additionally T3P_phpCRJackrabbit_CheckPermissionTest contained some uses of + instead of . for string concatenation, this created invalid input.

#6

Updated by Karsten Dambekalns over 14 years ago

Replying to [comment:5 karsten]:

(In r169) Fixes failures in T3P_phpCRJackrabbit_CheckPermissionTest caused by incorrectly set up account permissions:

Sorry, wrong ticket id used in commit message. Can this be corrected?

Also available in: Atom PDF