Bug #36996

DateTimeConverter

Added by Matthias Witte almost 7 years ago. Updated about 5 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
-
Target version:
-
Start date:
2012-05-09
Due date:
% Done:

0%

PHP Version:
Has patch:
No
Complexity:

Description

TYPO3.FLOW3/Classes/Property/TypeConverter

return new \TYPO3\FLOW3\Validation\Error('The date "%s" was not recognized (for format "%s").', 1307719788, array($dateAsString, $dateFormat));

At this position there should be thrown an Exception and returned NULL instead.

Something like:

throw new \TYPO3\FLOW3\Property\Exception\TypeConverterException(...
return NULL;


Related issues

Related to TYPO3.Flow - Feature #37294: Property converters should allow NULL results Closed 2012-05-19

History

#1 Updated by Adrian Föder almost 7 years ago

  • Status changed from New to Closed

as of http://git.typo3.org/FLOW3/Packages/TYPO3.FLOW3.git?a=commit;h=b47d1c61aaaf67c6d9c3379d87fe132ff7bded80 this is so far intended behavior. Please join the related issue if you have further comments on this.

Also available in: Atom PDF