Bug #37459

FormViewHelper with GET method and query parameters in action is not usable

Added by Christopher Hlubek over 9 years ago. Updated over 9 years ago.

Status:
Closed
Priority:
Should have
Category:
ViewHelpers
Target version:
-
Start date:
2012-05-24
Due date:
% Done:

0%

Estimated time:
Has patch:
No

Description

If the form viewhelper is used with method="GET" and the action attribute that is built (given with actionUri or using the URI builder) contains query paramters, they will be lost on form submission (http://www.w3.org/TR/html401/interact/forms.html#h-17.13.3.4).

The form viewhelper should parse query parameters in the action URI and prepend them as hidden fields in the form to pass them to the request that is submitted.


Related issues

Is duplicate of TYPO3.Fluid - Task #11636: Form viewhelper not functional with method GETResolvedChristopher Hlubek2010-12-22

Actions
#1

Updated by Bastian Waidelich over 9 years ago

  • Category set to ViewHelpers
  • Status changed from New to Closed
  • Assignee set to Bastian Waidelich

This is a duplicate of #11636 - i'll add your comments there

Also available in: Atom PDF