Bug #37507

Doctrine Collection add existing

Added by Carsten Bleicker over 9 years ago. Updated about 9 years ago.

Status:
Closed
Priority:
Should have
Category:
Persistence
Target version:
-
Start date:
2012-05-26
Due date:
% Done:

0%

Estimated time:
PHP Version:
Has patch:
No
Complexity:

Description

If you build up a nested form to UPDATE the party by a given subproperty input
<f:form.textfield property="primaryElectronicAddress.identifier" />
this will results in a doctrine exception:

#23000: SQLSTATE23000: Integrity constraint violation: 1062 Duplicate entry '54513027-6fce-4e4b-972a-8cd394d3ef87-e8dcf75e-b057-4f65-be8c-767' for key 'PRIMARY'

in my humble opinion either the doctrine array collection should check for allready existing and dont add a new index.
instead of a new it should use the old index. otherwise i have 2 indexes with the same uuid.

#1

Updated by Karsten Dambekalns about 9 years ago

  • Status changed from New to Closed
  • Assignee set to Karsten Dambekalns

Closing as duplicate of #37628. And this is not something that can be solved the Doctrine collections, as they are also used for non-unique collections.

Also available in: Atom PDF