Bug #37815

Object are not persisted

Added by Soren Malling over 7 years ago. Updated over 7 years ago.

Status:
Closed
Priority:
Must have
Category:
Persistence
Start date:
2012-06-07
Due date:
% Done:

100%

PHP Version:
Has patch:
No
Complexity:

Description

With the following injected repository

    /**
     * Team repository
     *
     * @var \Familiefejden\Domain\Repository\TeamRepository
     * @FLOW3\Inject
     */
    protected $teamRepository;

and calling the function

        $this->teamRepository->add($newTeam);

i expect to have my $newTeam (a valid!) object persisted, but nothing is persisted. I get forward to my next action ($this->forward(..)) with no exceptions.

Query log remains empty.

./flow3 doctrine:update commands works perfectly and tables are created


Related issues

Related to TYPO3.Flow - Bug #37574: ReflectionData is not regenerated automatically Resolved 2012-07-26

History

#1 Updated by Soren Malling over 7 years ago

ChristianM told me on IRC, that running ->persistAll() persists the values - but nothing is persisted if not running this command

#2 Updated by Soren Malling over 7 years ago

Tried to debug the issue and added some systemlogger->log call and all of a sudden (after rebuilding proxy classes - did a flow3:cache:flush --force) the injected repository was able to persist (without running persistAll)

#3 Updated by Karsten Dambekalns over 7 years ago

  • Project changed from TYPO3 Flow Base Distribution to TYPO3.Flow
  • Status changed from New to Accepted
  • Assignee set to Karsten Dambekalns

#4 Updated by Karsten Dambekalns over 7 years ago

  • Category set to Persistence
  • Status changed from Accepted to Closed
  • Target version set to 1.1
  • % Done changed from 0 to 100
  • Has patch set to No

Persistence works fine, judging from your description (it worked all of a sudden) I guess you fell victim to #37574

Also available in: Atom PDF