Bug #3945

Cannot redeclare PackageInterface

Added by Dmitry over 12 years ago. Updated about 11 years ago.

Status:
Closed
Priority:
Should have
Category:
Core
Target version:
-
Start date:
2009-07-18
Due date:
% Done:

0%

Estimated time:
PHP Version:
Has patch:
Complexity:

Description

I'm not sure who (FLOW3 or APC) is wrong. But I got error with APC.

[apc-error] Cannot redeclare class f3\flow3\package\packageinterface in <path>\Flow3\Distribution\trunk\Packages\Framework\FLOW3\Classes\Core\Bootstrap.php on line 28.

Configuration:
OS: Windows XP SP3
Apache: 2.2.11
PHP: php-5.3.0-Win32-VC9-x86.zip
APC: php_apc-trunk-20090717-5.3-vc9-x86.zip

#1

Updated by Robert Lemke over 12 years ago

  • Status changed from New to Needs Feedback

Hmm, I cannot reproduce this error on Mac OSX with Apache 2 and APC.

Does this error appear every time? Even after you cleared the FLOW3 caches (files in Data/Temporary/) and the APC opcode cache?

#2

Updated by Karsten Dambekalns about 12 years ago

  • Assignee set to Karsten Dambekalns
  • Target version deleted (283)

Hi Dmitry, any feedback?

#3

Updated by Irene Höppner about 12 years ago

I don't know, if this is relevant in this case, but the php-download-page (http://windows.php.net/download/) says:

If you are using PHP with Apache 1 or Apache2 from apache.org you need to use the VC6 versions of PHP.

If you are using PHP with IIS you should use the VC9 versions of PHP.

#4

Updated by Karsten Dambekalns about 12 years ago

  • Status changed from Needs Feedback to Closed

I'd suspect this was an issue with APC and/or PHP. Closing this - feel free to reopen if needed.

Also available in: Atom PDF