Bug #39647

TYPO3\FLOW3\Error\Exception thrown in file ErrorHandler.php

Added by Kay Strobach about 9 years ago. Updated about 9 years ago.

Status:
Closed
Priority:
-- undefined --
Assignee:
-
Category:
- Error Handler Report -
Target version:
-
Start date:
2012-08-09
Due date:
% Done:

0%

Estimated time:
PHP Version:
Has patch:
No
Complexity:

Description

Hello Guys,

using FLOW3 on Windows seems to be impossible :(

Regards
Kay

Warning: symlink(): Cannot create symlink, error code(1314) in D:\devenv\mowesII\www\flow3\Data\Temporary\Development\Cache\Code\FLOW3_Object_Classes\TYPO3_FLOW3_Resource_Publishing_FileSystemPublishingTarget_Original.php line 116
21 TYPO3\FLOW3\Error\ErrorHandler::handleError(2, "symlink(): Cannot create symlink, error code(1314)", "D:\devenv\mowesII\www\flow3\Data\Temporary\Develop…Publishing_FileSystemPublishingTarget_Original.php", 116, array)

20 symlink("D:/devenv/mowesII/www/flow3/Packages/Framework/TYPO3.FLOW3/Resources/Public", "D:/devenv/mowesII/www/flow3/Web/_Resources/Static/Packages/TYPO3.FLOW3")

19 TYPO3\FLOW3\Resource\Publishing\FileSystemPublishingTarget_Original::publishStaticResources("D:/devenv/mowesII/www/flow3/Packages/Framework/TYPO3.FLOW3/Resources/Public/", "Packages/TYPO3.FLOW3/")

18 TYPO3\FLOW3\Resource\Publishing\ResourcePublisher_Original::publishStaticResources("D:/devenv/mowesII/www/flow3/Packages/Framework/TYPO3.FLOW3/Resources/Public/", "Packages/TYPO3.FLOW3/")

17 TYPO3\FLOW3\Resource\ResourceManager_Original::publishPublicPackageResources(array)

16 TYPO3\FLOW3\Core\Booting\Scripts::initializeResources(TYPO3\FLOW3\Core\Bootstrap)

15 call_user_func(array, TYPO3\FLOW3\Core\Bootstrap)

14 TYPO3\FLOW3\Core\Booting\Step::__invoke(TYPO3\FLOW3\Core\Bootstrap)

13 TYPO3\FLOW3\Core\Booting\Sequence::invokeStep(TYPO3\FLOW3\Core\Booting\Step, TYPO3\FLOW3\Core\Bootstrap)

12 TYPO3\FLOW3\Core\Booting\Sequence::invokeStep(TYPO3\FLOW3\Core\Booting\Step, TYPO3\FLOW3\Core\Bootstrap)

11 TYPO3\FLOW3\Core\Booting\Sequence::invokeStep(TYPO3\FLOW3\Core\Booting\Step, TYPO3\FLOW3\Core\Bootstrap)

10 TYPO3\FLOW3\Core\Booting\Sequence::invokeStep(TYPO3\FLOW3\Core\Booting\Step, TYPO3\FLOW3\Core\Bootstrap)

9 TYPO3\FLOW3\Core\Booting\Sequence::invokeStep(TYPO3\FLOW3\Core\Booting\Step, TYPO3\FLOW3\Core\Bootstrap)

8 TYPO3\FLOW3\Core\Booting\Sequence::invokeStep(TYPO3\FLOW3\Core\Booting\Step, TYPO3\FLOW3\Core\Bootstrap)

7 TYPO3\FLOW3\Core\Booting\Sequence::invokeStep(TYPO3\FLOW3\Core\Booting\Step, TYPO3\FLOW3\Core\Bootstrap)

6 TYPO3\FLOW3\Core\Booting\Sequence::invokeStep(TYPO3\FLOW3\Core\Booting\Step, TYPO3\FLOW3\Core\Bootstrap)

5 TYPO3\FLOW3\Core\Booting\Sequence::invokeStep(TYPO3\FLOW3\Core\Booting\Step, TYPO3\FLOW3\Core\Bootstrap)

4 TYPO3\FLOW3\Core\Booting\Sequence::invoke(TYPO3\FLOW3\Core\Bootstrap)

3 TYPO3\FLOW3\Http\RequestHandler::boot()

2 TYPO3\FLOW3\Http\RequestHandler::handleRequest()

1 TYPO3\FLOW3\Core\Bootstrap::run()

Please include more helpful information!

#1

Updated by Adrian Föder about 9 years ago

  • Status changed from New to Closed

Kay, not at all, it works fine on current Windows OSes.
Quick solution for your case: always run your CLI with Admin privileges (ie Start menu, type "cmd" and pres Ctrl+Shift while hitting Return, you should get a UAC prompt and land under C:\Windows\system32.

besides, check http://wiki.typo3.org/FLOW3_Installation_Hints for additional information. My Apache runs as system service, is hence also allowed to create symlinks.

I'll close this issue; that's no offense, don't hesitate to re-open, ask additional questions or join #flow3 at freenode.net (IRC).

Also available in: Atom PDF