Bug #40625

InvalidArgumentException thrown in file Headers.php

Added by Ferdinand Kuhl about 9 years ago. Updated about 9 years ago.

Status:
Closed
Priority:
-- undefined --
Assignee:
Category:
Http
Target version:
-
Start date:
2012-09-04
Due date:
% Done:

0%

Estimated time:
PHP Version:
Has patch:
No
Complexity:

Description

The "Set-Cookie" headers must be set via setCookie().
28 TYPO3\FLOW3\Http\Headers::set("Set-Cookie", "JSESSIONID=0000bpxjzMKKBYiEQM5yG5xd5CG:15rk67n7r; Path=/", boolean)

If the foreign webserver sends an header "Set-Cookie" FLOW3 throws an Exception, and breaks header - parsing. So no content from Servers sending cookies can be extracted.


Related issues

Is duplicate of TYPO3.Flow - Bug #40626: Cookie - Setting throws exception in Http\Response ResolvedRobert Lemke2012-09-04

Actions
#1

Updated by Ferdinand Kuhl about 9 years ago

Sorry this is an duplicate of #40626.

Pressed the buttons in wrong order. :(

#2

Updated by Robert Lemke about 9 years ago

  • Status changed from New to Closed

Also available in: Atom PDF