Task #41654

Symlinks in ZIP install package causes setup to fail

Added by Jochen Weiland over 9 years ago. Updated about 9 years ago.

Status:
Resolved
Priority:
Must have
Category:
Setup
Target version:
-
Start date:
2012-10-07
Due date:
% Done:

100%

Estimated time:

Description

When unzipping the file TYPO-Neos-1.0-alpha1, a number of symlinks with nonexistent targets are created in the Web/_Resources/Static/Packages folder:

linking: TYPO3-Neos-1.0-alpha1/Web/_Resources/Static/Packages/TYPO3.Aloha  -> /Volumes/data/htdocs/neos-build/Packages/Application/TYPO3.Aloha/Resources/Public 
linking: TYPO3-Neos-1.0-alpha1/Web/_Resources/Static/Packages/TYPO3.ExtJS -> /Volumes/data/htdocs/neos-build/Packages/Application/TYPO3.ExtJS/Resources/Public
linking: TYPO3-Neos-1.0-alpha1/Web/_Resources/Static/Packages/TYPO3.Flow -> /Volumes/data/htdocs/neos-build/Packages/Framework/TYPO3.Flow/Resources/Public
linking: TYPO3-Neos-1.0-alpha1/Web/_Resources/Static/Packages/TYPO3.Fluid -> /Volumes/data/htdocs/neos-build/Packages/Framework/TYPO3.Fluid/Resources/Public
linking: TYPO3-Neos-1.0-alpha1/Web/_Resources/Static/Packages/TYPO3.PhoenixDemoTypo3Org -> /Volumes/data/htdocs/neos-build/Packages/Sites/TYPO3.PhoenixDemoTypo3Org/Resources/Public
linking: TYPO3-Neos-1.0-alpha1/Web/_Resources/Static/Packages/TYPO3.Setup -> /Volumes/data/htdocs/neos-build/Packages/Application/TYPO3.Setup/Resources/Public
linking: TYPO3-Neos-1.0-alpha1/Web/_Resources/Static/Packages/TYPO3.TYPO3 -> /Volumes/data/htdocs/neos-build/Packages/Application/TYPO3.TYPO3/Resources/Public
linking: TYPO3-Neos-1.0-alpha1/Web/_Resources/Static/Packages/Twitter.Bootstrap -> /Volumes/data/htdocs/neos-build/Packages/Application/Twitter.Bootstrap/Resources/Public
(...)
finishing deferred symbolic links:
TYPO3-Neos-1.0-alpha1/Web/_Resources/Static/Packages/TYPO3.Aloha -> /Volumes/data/htdocs/neos-build/Packages/Application/TYPO3.Aloha/Resources/Public
TYPO3-Neos-1.0-alpha1/Web/_Resources/Static/Packages/TYPO3.ExtJS -> /Volumes/data/htdocs/neos-build/Packages/Application/TYPO3.ExtJS/Resources/Public
TYPO3-Neos-1.0-alpha1/Web/_Resources/Static/Packages/TYPO3.Flow -> /Volumes/data/htdocs/neos-build/Packages/Framework/TYPO3.Flow/Resources/Public
TYPO3-Neos-1.0-alpha1/Web/_Resources/Static/Packages/TYPO3.Fluid -> /Volumes/data/htdocs/neos-build/Packages/Framework/TYPO3.Fluid/Resources/Public
TYPO3-Neos-1.0-alpha1/Web/_Resources/Static/Packages/TYPO3.PhoenixDemoTypo3Org -> /Volumes/data/htdocs/neos-build/Packages/Sites/TYPO3.PhoenixDemoTypo3Org/Resources/Public
TYPO3-Neos-1.0-alpha1/Web/_Resources/Static/Packages/TYPO3.Setup -> /Volumes/data/htdocs/neos-build/Packages/Application/TYPO3.Setup/Resources/Public
TYPO3-Neos-1.0-alpha1/Web/_Resources/Static/Packages/TYPO3.TYPO3 -> /Volumes/data/htdocs/neos-build/Packages/Application/TYPO3.TYPO3/Resources/Public
TYPO3-Neos-1.0-alpha1/Web/_Resources/Static/Packages/Twitter.Bootstrap -> /Volumes/data/htdocs/neos-build/Packages/Application/Twitter.Bootstrap/Resources/Public

The setup program tries to create the folders, e.g. TYPO3.Aloha in the Packages folder. Since the symlink already exists, the creating of the folder fails with a fatal error:

Uncaught Exception
Could not create directory
"/.../TYPO3-Neos-1.0-alpha1/Web/_Resources/Static/Packages/TYPO3.Aloha/Aloha"!

Temporary solution:
Delete the symlinks in the Web/_Resources/Static/Packages folder after unzipping.

#1

Updated by Karsten Dambekalns about 9 years ago

  • Status changed from New to Accepted
  • Assignee set to Karsten Dambekalns
#2

Updated by Karsten Dambekalns about 9 years ago

  • Status changed from Accepted to Resolved
  • % Done changed from 0 to 100

I uploaded a new archive without the symlinks and empty caches, that should work more reliable.

Also available in: Atom PDF