Bug #42770

Routing includes parameters from the current request

Added by Aske Ertmann almost 9 years ago. Updated almost 9 years ago.

Status:
Resolved
Priority:
Should have
Assignee:
-
Category:
MVC - Routing
Start date:
2012-11-07
Due date:
% Done:

100%

Estimated time:
PHP Version:
Has patch:
No
Complexity:
medium

Description

I believe that after https://review.typo3.org/#/c/15261/ some routing arguments from the current request is passed along to all new links created with the uri builder. This should not happen and leads to some very weird side effects.

I need to look further into the problem, but so far I've found that it happens for requests to the node controller ext direct service in Neos and as well for modules. The modules has a very special route part handling, so that is probably not the best place to start.

An example is the page tree making a request for the nodes and that request uses the uri builder to create links to the nodes, but those links are appended with the ajax request's parameters which of course they shouldn't.

Example "nodeData[contentType]=TYPO3.Neos.ContentTypes:Page&nodeData[properties][title]=test&position=into&@subpackage=&__csrfToken=4cc446feb743b38a5f47db7fc500251e" is added to the links


Related issues

Related to TYPO3.Flow - Bug #44139: UriBuilder includes all arguments of namespaced sub requestResolved2012-12-19

Actions
#1

Updated by Bastian Waidelich almost 9 years ago

Hi Aske,
did you already find out more?
I stumbled upon paginators not working any more (you can't get back to the first page, because the UriBuilder will always append the widget arguments of the current request)..

#2

Updated by Marc Neuhaus almost 9 years ago

I can confirm this issue, current request arguments aren't reset for the request generating a uri.

The issue seems to be here:
http://git.typo3.org/FLOW3/Packages/TYPO3.FLOW3.git?a=blob;f=Classes/TYPO3/Flow/Mvc/Routing/UriBuilder.php;h=b6362fde334fe39c316353d337b459ea97cb4df1;hb=fefb00eadefe768c1e8415fc6faac6b1f84c81bc#l420

I'll try to dig deeper tonight/tomorrow

#3

Updated by Gerrit Code Review almost 9 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/16736

#4

Updated by Gerrit Code Review almost 9 years ago

Patch set 2 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/16736

#5

Updated by Gerrit Code Review almost 9 years ago

Patch set 3 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/16736

#6

Updated by Gerrit Code Review almost 9 years ago

Patch set 4 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/16736

#7

Updated by Gerrit Code Review almost 9 years ago

Patch set 5 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/16736

#8

Updated by Gerrit Code Review almost 9 years ago

Patch set 6 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/16736

#9

Updated by Anonymous almost 9 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

Also available in: Atom PDF