Feature #43424

Support subpackage when kickstarting model & repository

Added by Karsten Dambekalns almost 7 years ago. Updated almost 5 years ago.

Status:
Under Review
Priority:
Should have
Start date:
2012-11-29
Due date:
% Done:

0%


Description

The kickstart for controllers allows the use of subpackages, this is missing for model and repository.

History

#1 Updated by Gerrit Code Review almost 7 years ago

  • Status changed from Accepted to Under Review

Patch set 3 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/16828

#2 Updated by Gerrit Code Review almost 7 years ago

Patch set 5 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/16828

#3 Updated by Gerrit Code Review almost 7 years ago

Patch set 6 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/16828

#4 Updated by Gerrit Code Review almost 7 years ago

Patch set 7 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/16828

#5 Updated by Karsten Dambekalns almost 7 years ago

  • Target version changed from 2.0 beta 1 to 2.0

#6 Updated by Karsten Dambekalns about 6 years ago

  • Target version changed from 2.0 to 2.0.1

#7 Updated by Oliver Eglseder almost 5 years ago

Hey Karsten,

i would appreciate if you could revive this ticket.

Aside of the current topic, there are some more problems which occured.
I kickstarted an actioncontroller:
./flow kickstart:actioncontroller MyVendor.MyPackage/SubPackage MyTest --generate-related --generate-actions --generate-templates

As result, the actioncontroller got created as expected, but the Repository and Model file locations were outside of the subpackage directory but the annotations included the supackage.

On top of that, the action urls which are built contain the argument supackage as strtolower(subPackageKey). When following the link (http://flow-test.dev/myvendor.mypackage/mytest/new?%40subpackage=subpackage) i get the exception
Template could not be loaded.
I tried "resource://MyVendor.MyPackage/Private/Templates/subpackage/MyTest/New.html"

because the subpacke-key is not converted to the matching non-lowercase subpackage but taken for building the template path (which does not exist, since "subpackage" is written in CamelCase)

If you need more Feedback, feel free to contact me. (I rarely get notifications from forge)

Also available in: Atom PDF