Bug #43511

Page TSconfig option mod.SHARED.colPos_list does not work anymore

Added by Chris topher almost 9 years ago. Updated almost 3 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Backend User Interface
Target version:
-
Start date:
2012-12-02
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
6.0
PHP Version:
5.4
Tags:
Complexity:
Is Regression:
Yes
Sprint Focus:

Description

The Page TSconfig option mod.SHARED.colPos_list does no longer work in TYPO3 6.0. E.g. mod.SHARED.colPos_list = 0 should only display column 0, but it does not.

Instead of showing only the columns given in the list, the default columns are always shown.

I think the problem is located in typo3/sysext/backend/Classes/Controller/PageLayoutController.php, lines 470 - 476.

Seems like the issue is caused by changes in the integration of the backend layouts... The TSconfig options just are not checked anymore.


Related issues

Related to TYPO3 Core - Bug #39967: mod.SHARED.colPos_list is not taken into account any moreClosed2012-08-19

Actions
#1

Updated by Chris topher almost 9 years ago

If it should be important: I did an update to 6.0 and I went through the update wizards, but I have not changed anything with the backend layouts.

#2

Updated by Klaus Weidenbach almost 9 years ago

In the "What's New" slides I found that this is now done with backend layouts. But I don't know if backend layouts is a complete replacement for this. At least in the TSconfig QuickReference this option is still present.

#3

Updated by Chris topher over 8 years ago

  • Status changed from New to Closed
  • Assignee set to Chris topher
  • Target version deleted (6.0.1)
  • % Done changed from 0 to 100

Won't fix. Backend Layouts in fact are the new way to do it.

See #47071.

#4

Updated by Jo Hasenau over 7 years ago

See #39967 - this has been a regression and of course the bug should be fixed.

#5

Updated by Markus Klein over 7 years ago

  • Status changed from Closed to Accepted
  • Assignee deleted (Chris topher)
  • Is Regression set to Yes
#6

Updated by Mathias Schreiber over 6 years ago

  • Status changed from Accepted to Resolved

fixed on master

#7

Updated by Benni Mack almost 3 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF