Bug #4409

@inject comment property isn't working

Added by ziyad saeed about 12 years ago. Updated almost 11 years ago.

Status:
Closed
Priority:
Should have
Category:
Object
Start date:
2009-08-31
Due date:
% Done:

0%

Estimated time:
PHP Version:
Has patch:
Complexity:

Description

In the Getting Started guide, a blog controller is created that has a blogRepository property.

/**
 * @var \F3\Blog\Domain\Repository\BlogRepository
 * @inject
 */
protected $blogRepository;

When the code is run the blogRepository property is null. The blogRepository object isn't being injected, which in turn gives a "Call to a member function findAll() on a non-object" error.

I'm posting this issue here cause no one seems to be monitoring the getting started issue tracker


Related issues

Is duplicate of Getting Started - Bug #4325: Call to a member function findAll() on a non-objectResolvedKarsten Dambekalns2009-08-26

Actions
#1

Updated by Karsten Dambekalns about 12 years ago

  • Category set to Object
  • Status changed from New to Closed
  • Assignee set to Karsten Dambekalns

Also available in: Atom PDF