Feature #44123

Make the "Flow requires the PHP setting "date.timezone"" error more beautiful

Added by Ernesto Baschny over 6 years ago. Updated over 5 years ago.

Status:
New
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2012-12-19
Due date:
% Done:

0%

PHP Version:
Has patch:
No
Complexity:

Description

My first impression with Flow/Neos a very unstylish "echo" error message with a die():

Flow requires the PHP setting "date.timezone" to be set. (Error #1342087777)

This was introduced in #37438. The default "date.timezone" is empty in most distributions, so I guess there will be others facing the same first impression.

My suggestion would be to make this error message more "stylish" and give some more help about how to / where change it (you use to give paths for Debian-like people). It should look more like the exceptions found later on.

On a more broader question: Why is this date.timezone required by the "Bootstrap" already? I suppose Flow has many other "PHP dependencies" (required settings, required loaded modules, required permissions etc), which should all be checked in this first installation step anyway. There is a step in /setup which tells me "Your environment seems suited for bla bla" and then redirects to a further step. Wouldn't this be a better place to check for this dependency?


Related issues

Related to TYPO3.Flow - Feature #37438: Remove setting default timezone on its own Resolved 2012-05-23
Related to TYPO3.Flow - Bug #54181: Use date_default_timezone_get() instead of ini_get('date.timezone') New 2013-12-04

Also available in: Atom PDF